$re = '/(?<marked>\w+$)/m';
$str = 'A file has been marked as Removed';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);