$re = '/^(?=.*param1=([^&]+)|)(?=.*param2=([^&]+)|)(?=.*param3=([^&]+)|).+$/m';
$str = '?param1=test1¶m2=test2¶m3=test3
?param1=test1
?param2=test2¶m1=test1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);