package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`a(.*)b|a([\s\S]*?)b`)
var str = `axxxxxxxxxxxxxxxxxxb
a
xxxx
b
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}