$re = '/a(.*)b|a([\s\S]*?)b/';
$str = 'axxxxxxxxxxxxxxxxxxb
a
xxxx
b
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);