using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\#(?<my_field>[^\#]*)";
string input = @"opIcarus #opBlackOctober #opSacred #opMASSHACK ENGAGED https://t.co/JiWVA4kOXr";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}