re = /\#(?<my_field>[^\#]*)/
str = 'opIcarus #opBlackOctober #opSacred #opMASSHACK ENGAGED https://t.co/JiWVA4kOXr'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end