package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\A\s*\\(document(?:style|class))\s*(\[[^]]*\])?\s*\{(?<class>[^}]+)\}`)
var str = `\documentclass[...]{...}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}