$re = '/\A\s*\\\\(document(?:style|class))\s*(\[[^]]*\])?\s*\{(?<class>[^}]+)\}/m';
$str = '\\documentclass[...]{...}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);