$re = '/\$(\w+).*\$(\w+).*\$(\w+)/m';
$str = '"hi $my name $is Chad, how are $you today"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);