re = /\$(\w+).*\$(\w+).*\$(\w+)/m
str = '"hi $my name $is Chad, how are $you today"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end