import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*?1.{0,5}2.*|.*2(*COMMIT)3.*";
final String string = "1.....23\n"
+ "1.....21\n"
+ "23......\n"
+ "12.....1\n"
+ "1...2...\n"
+ "....23..\n"
+ "213....2\n"
+ "1......2\n"
+ "213....3\n"
+ "2.....21";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}