const regex = /.*?1.{0,5}2.*|.*2(*COMMIT)3.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?1.{0,5}2.*|.*2(*COMMIT)3.*', 'gm')
const str = `1.....23
1.....21
23......
12.....1
1...2...
....23..
213....2
1......2
213....3
2.....21`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}