package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+)(?:\s\[(.+?)\]\((.+?)\))?`)
var str = `textA [aaa](bbb) textB [ccc](ddd) textC`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}