$re = '/(\w+)(?:\s\[(.+?)\]\((.+?)\))?/m';
$str = 'textA [aaa](bbb) textB [ccc](ddd) textC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);