package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[(\d+)`)
var str = `blablablaa [1 holalalala [8 ahahahahaha [25`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}