$re = '/\[(\d+)/';
$str = 'blablablaa [1 holalalala [8 ahahahahaha [25';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);