$re = '/(?<=Service For\s).+$/s';
$str = 'Service For
12345 apple street
Tampa,FL 34567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);