re = /(?<=Service For\s).+$/
str = 'Service For
12345 apple street
Tampa,FL 34567'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end