re = /[^\.]+[.][^\.]+[.][^\.]+[.]((?:Gross|Tare)Calibration)+[.][^\.]+[.][^\.]+?(\s*)/
str = 'abc.ac.b.GrossCalibration.qualcosa.c
abc.ac.b.TareCalibration.qualcosa.c
abc.ac.b.CiaoCalibration.qualcosa.c
abc.ac.b.NoCalibration.qualcosa.c
abc.ac.b.Calibration.qualcosa.c'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end