using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Windows\sNT\s10.0;\s(Win64|WOW64)";
string input = @"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Safari/537.36";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}