using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=((\d+(,\s*)?)+$)|((\[\d+,\s*\d+\](,\s*)?)+$))";
string input = @"1,2,3888, 4,5
[460, 3], [123,321],[900,123]
1, [1]
1,not
scott
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}