use strict;
my $str = '1,2,3888, 4,5
[460, 3], [123,321],[900,123]
1, [1]
1,not
scott
';
my $regex = qr/^(?=((\d+(,\s*)?)+$)|((\[\d+,\s*\d+\](,\s*)?)+$))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}