package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^,-]+)(-[^,-]+)?`)
var str = `UMC12I-1234,CSM3-123,VQ`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}