$re = '/\bwx\.data\.(?!get|update)\S+/m';
$str = 'wx.data.xxx
wx.data.update
wx.data.get';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);