re = /\bwx\.data\.(?!get|update)\S+/m
str = 'wx.data.xxx
wx.data.update
wx.data.get'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end