import re
regex = re.compile(r"(?:^|\s)(?i)(?<prefix>(?:mrs?\.|dr\.)?)(?-i)(?<name>\s*[A-Z][\w\.-]+(?:(?:^|\s)[A-Z][\w\.-]+)*)(?i)(?<suffix>(?:\s*[js]r|i{1,3}|i?v)?\.?)(?-i)", flags=re.MULTILINE)
test_str = "The annual community picnic was a lively affair, with everyone from the neighborhood gathering in the park. Little Sarah excitedly ran around chasing bubbles blown by her dad, Hubert Blaine Wolfeschlegelsteinhausenbergerdorff sr., while her older brother, Michael, was engrossed in a spirited game of frisbee with his friends, Dr. Alex and Maya. Meanwhile, Mrs. Mary T. White-Holland was busy setting up the potluck spread, which included her famous potato salad, while Mr. Lee was grilling juicy burgers on the barbecue, all while sharing friendly banter with his neighbor, Lyndon B. Johnson. The afternoon was filled with laughter, delicious food, and the warm sense of community that made this yearly event so special in New York City; then JT finally arrived!"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")