re = /(?:^|\s)(?i)(?<prefix>(?:mrs?\.|dr\.)?)(?-i)(?<name>\s*[A-Z][\w\.-]+(?:(?:^|\s)[A-Z][\w\.-]+)*)(?i)(?<suffix>(?:\s*[js]r|i{1,3}|i?v)?\.?)(?-i)/m
str = 'The annual community picnic was a lively affair, with everyone from the neighborhood gathering in the park. Little Sarah excitedly ran around chasing bubbles blown by her dad, Hubert Blaine Wolfeschlegelsteinhausenbergerdorff sr., while her older brother, Michael, was engrossed in a spirited game of frisbee with his friends, Dr. Alex and Maya. Meanwhile, Mrs. Mary T. White-Holland was busy setting up the potluck spread, which included her famous potato salad, while Mr. Lee was grilling juicy burgers on the barbecue, all while sharing friendly banter with his neighbor, Lyndon B. Johnson. The afternoon was filled with laughter, delicious food, and the warm sense of community that made this yearly event so special in New York City; then JT finally arrived!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end