re = /(\B(".+?")\B|\B('.+?')\B|\B(`.+?`)\B)/m
str = '"Lorem ipsum dolor sit amet", consectetur adipisicing elit, "\'sed do eiusmod tempor,\'" incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, `quis nostrud` exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. `Duis aute irure dolor` in "reprehenderit in voluptate" velit esse cillum \'dolore eu fugiat nulla\' pariatur. '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result