// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(\B(".+?")\B|\B('.+?')\B|\B(`.+?`)\B)"#).unwrap();
let string = "\"Lorem ipsum dolor sit amet\", consectetur adipisicing elit, \"'sed do eiusmod tempor,'\" incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, `quis nostrud` exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. `Duis aute irure dolor` in \"reprehenderit in voluptate\" velit esse cillum 'dolore eu fugiat nulla' pariatur. ";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}