import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bhome[\\W_]+based[\\W_]+online[\\W_]+job(?:s)?\\b";
final String string = "We are Hiring - Earn Rs.15000/- Per month - Simple Copy Paste Jobs\n\n"
+ "Earn Rs.25000/- per month - Simple online Jobs - Are You Looking for Home-Based Online Jobs? - Are You a Student, Housewife, jobseeker ? - Are you ready to Work 1 to 2 Hours daily Online? - Do You need Guaranteed Payment Monthly? Then this is for You, - Clicking on their Advertisement E-mails. - Submitting their Data's online. - Reading their Advertisement Sms. - Filling Forms on their websites, etc,. FREE to Join >> http://dailyonlinejobs.com DPJ4602162 07 10 2019 20:20:50\n\n"
+ "http://www.4cashpath.com/ My last month's online earning was $17593 just by doing an easy job online. Easiest home based online job to earn extra dollars every month just by doing work for maximum 2 to 3 hrs a day. I have joined this job about 3 months ago and in my first month i have made $12k+ easily without any special online experience. Everybody on this earth can get this job today and start making cash online by just follow details on this website.........";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}