$re = '/(?<!<)span(?!>)/m';
$str = 'cool span<span class=\'Span\'> span spanspan the span</span> what a span';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);