re = /(?<!<)span(?!>)/m
str = 'cool span<span class=\'Span\'> span spanspan the span</span> what a span'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end