#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?=.*?\p{N})(?=.*?[\p{S}\p{P} ])(?=.*?\p{Lu})(?=.*?\p{Ll}))[^\p{C}]{8,16}$"
Local $sString = "********** VALID **********" & @CRLF & _
"Password1!" & @CRLF & _
"TestPass###231" & @CRLF & _
"My Pass#123~12`1" & @CRLF & _
"!#$Afs1!@(*''" & @CRLF & _
"VDFt35q#@$@" & @CRLF & _
"éA1!@#!@#!" & @CRLF & _
"" & @CRLF & _
"********* INVALID *********" & @CRLF & _
"PASSWORD1!" & @CRLF & _
"password1!" & @CRLF & _
"Password1" & @CRLF & _
"Password" & @CRLF & _
"Passw1!" & @CRLF & _
"ThisIsMySuperLongPassword1!" & @CRLF & _
"Ae! 1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")