$re = '/^(?:(?=.*?\p{N})(?=.*?[\p{S}\p{P} ])(?=.*?\p{Lu})(?=.*?\p{Ll}))[^\p{C}]{8,16}$/m';
$str = '********** VALID **********
Password1!
TestPass###231
My Pass#123~12`1
!#$Afs1!@(*\'\'
VDFt35q#@$@
éA1!@#!@#!
********* INVALID *********
PASSWORD1!
password1!
Password1
Password
Passw1!
ThisIsMySuperLongPassword1!
Ae! 1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);