const regex = /(.+Encryption Algorithms:)|([a-z-0-9]+)(?:,|\s)|(MAC.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+Encryption Algorithms:)|([a-z-0-9]+)(?:,|\\s)|(MAC.+)', 'gm')
const str = `SSH Enabled - version 2.0 Authentication methods:publickey,keyboard-interactive,password Encryption Algorithms:aes128-ctr,aes192-ctr,aes256-ctr,aes128-cbc,3des-cbc,aes192-cbc,aes256-cbc MAC Algorithms:hmac-sha1,hmac-sha1-96 Authentication timeout: 120 secs; Authentication retries: 3 Minimum expected Diffie Hellman key size : 1024 bits IOS Keys in SECSH format(ssh-rsa, base64 encoded):`;
const subst = `$2 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);