$re = '/(.+Encryption Algorithms:)|([a-z-0-9]+)(?:,|\s)|(MAC.+)/m';
$str = 'SSH Enabled - version 2.0 Authentication methods:publickey,keyboard-interactive,password Encryption Algorithms:aes128-ctr,aes192-ctr,aes256-ctr,aes128-cbc,3des-cbc,aes192-cbc,aes256-cbc MAC Algorithms:hmac-sha1,hmac-sha1-96 Authentication timeout: 120 secs; Authentication retries: 3 Minimum expected Diffie Hellman key size : 1024 bits IOS Keys in SECSH format(ssh-rsa, base64 encoded):';
$subst = "$2 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;