import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Legal Description:)(\\n)(.*)^(?:(?!Property Use:).)*";
final String string = "General Info\n"
+ "Status: Certified\n"
+ "ACCOUNT\n"
+ "Property ID:\n"
+ "408123\n"
+ "Geographic ID:\n"
+ "Type:\n"
+ "P\n"
+ "Agent:\n"
+ "LETS GO TAX SERVICES - PO BOX 111\n"
+ "(Authorized)\n"
+ "Legal Description:\n"
+ "AREA THAT I WANT TO CAPTURE\n"
+ "Property Use:\n"
+ "OWNER\n"
+ "Name:\n"
+ "ABCD GAME SERVICE LLC\n"
+ "Secondary Name:\n"
+ "ATTN ACCTS PAYABLE\n"
+ "Mailing Address:\n"
+ "PO BOX 2222 NEW YORK NY 222515-12354\n"
+ "Owner ID:\n"
+ "123456";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}