#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "&(?!(?:apos|quot|[gl]t|amp);|#)"
Local $sString = "<field>& is escaped</field>" & @CRLF & _
"<field>"also escaped"</field>" & @CRLF & _
"<field>is & "not" escaped</field>" & @CRLF & _
"<field>is " and is not & escaped</field>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")