#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Trade Disclosures \(.\)(.*?)$"
Local $sString = " TypePrice Principal AmountCommission (orComm. Equiv.) Net ProceedsFx RateSett CcySettlement TotalTrade Disclosures (b)19330THNM3J 21428108 US46432F8427 IEFATERREBONNEINVESTMENTS LPN USD 155,589 SHS 64.3067* 10,005,415.15 777.95 10,006,193.10 USD 10,006,193.10 iii, xiv"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")