# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Trade Disclosures \(.\)(.*?)$"
test_str = " TypePrice Principal AmountCommission (orComm. Equiv.) Net ProceedsFx RateSett CcySettlement TotalTrade Disclosures (b)19330THNM3J 21428108 US46432F8427 IEFATERREBONNEINVESTMENTS LPN USD 155,589 SHS 64.3067* 10,005,415.15 777.95 10,006,193.10 USD 10,006,193.10 iii, xiv"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.