package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\((.*?)\)`)
var str = `(123r) qwegf(telnet1) telnet2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}