$re = '/\((.*?)\)/';
$str = '(123r) qwegf(telnet1) telnet2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);