use strict;
my $str = '<div class="brn-answer__content sg-content-box__content">
<div class="sg-content-box sg-content-box--spaced-bottom">
<div class="brn-answer__text">
<div class="sg-text">
Тут немного текста
</div>
</div>
<div class="brn-attachments brn-attachments--spaced-top">
<a href="https://site.ru/files/de1/b96e8076bba5b1c3bbd39a53d301c8a5.jpg" class="brn-attachments__attachment" target="_blank">
<div class="sg-box sg-box--image-wrapper ">
<img class="sg-box__image" src="https://site.ru/files/de1/b96e8076bba5b1c3bbd39a53d301c8a5.jpg" title="Photo" alt="">
</div>';
my $regex = qr/src=\"(.*?)\"/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}