import re
regex = re.compile(r"src=\"(.*?)\"")
test_str = ("<div class=\"brn-answer__content sg-content-box__content\">\n"
"<div class=\"sg-content-box sg-content-box--spaced-bottom\">\n"
"<div class=\"brn-answer__text\">\n"
"<div class=\"sg-text\">\n"
"Тут немного текста\n"
"</div>\n"
"</div>\n"
"<div class=\"brn-attachments brn-attachments--spaced-top\">\n"
"<a href=\"https://site.ru/files/de1/b96e8076bba5b1c3bbd39a53d301c8a5.jpg\" class=\"brn-attachments__attachment\" target=\"_blank\">\n"
"<div class=\"sg-box sg-box--image-wrapper \">\n"
"<img class=\"sg-box__image\" src=\"https://site.ru/files/de1/b96e8076bba5b1c3bbd39a53d301c8a5.jpg\" title=\"Photo\" alt=\"\">\n"
"</div>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")