using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^\[)[^\]]*";
string input = @"[text1]Blablablabla[text2]blalal
[text1]Blablablabla[text2]blalal [text1]Blablablabla[text2]blalal";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}