re = /(?<=^\[)[^\]]*/m
str = '[text1]Blablablabla[text2]blalal
[text1]Blablablabla[text2]blalal [text1]Blablablabla[text2]blalal'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end