$re = '/"id":"(.*?)(","success":)(.*?)(,)/m';
$str = '{"id":"500e000000DmpnJAAR","success":true,"errors":[]}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);