re = /"id":"(.*?)(","success":)(.*?)(,)/m
str = '{"id":"500e000000DmpnJAAR","success":true,"errors":[]}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end