$re = '/^(?:\/[a-z]{2})?\/user/m';
$str = '/en/user/abc
/de/user/abc
/nl/user/abc
/user/abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);