re = /^(?:\/[a-z]{2})?\/user/m
str = '/en/user/abc
/de/user/abc
/nl/user/abc
/user/abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end